Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Latence à la modification des noeuds
#1
Bonjour,
J'accuse un problème de latence lorsque je modifie un noeud. C'est très relatif, ça peut prendre 1/10ème de seconde comme 1 ou 2 secondes (je vous explique ce détail plus bas).
Si cela semble mineur, expliqué comme ça, comme j'ai BEAUCOUP de noeuds à modifier sur mes illustrations, je perds un temps phénoménale là-dessus (sans doute plus du double de temps).
Aussi, je me suis décidée à prendre le temps de demander de l'aide ici.

Je précise que j'ai lu et testé les solutions des posts suivants :
https://www.affinity-forum.fr/showthread...ht=latence
https://www.affinity-forum.fr/showthread...ht=latence
https://www.affinity-forum.fr/showthread...ht=latence
https://www.affinity-forum.fr/showthread...ht=latence
Ce dernier lien étant le plus complet Smile
J'ai essayé de faire les choses bien pour vous éviter de perdre votre temps.

Je vous résume donc certains éléments :
  • J'ai affinity design depuis plusieurs mois. J'ai commencé avec le 1.8 puis le 1.9, et 1.9.2. Le problème de latence est le même quelle que soit le version utilisée.
  • J'ai aussi été sous Linux avec un vieux PC de 8 Go de RAM puis sous Windows 10 avec le même PC, puis sous un nouveau PC (actuel) avec Windows 10 et 64 Go de RAM, et le problème est à chaque fois le même.
  • J'ai décoché l'accelération matérielle, mais cela ne change rien.
  • J'ai augmenté ma RAM utilisée de 22 Go à 44 Go (sur 64), mais cela ne change rien.
  • J'ai changé la carte sur laquelle le logiciel travaillait (carte graphique), mais c'est pire. Je suis donc revenu à celle par défaut.
  • J'ai aussi abaissé l'historique d'annulation à 8 pour voir, mais cela n'a rien changé.
  • "Enregistrer l'historique dans le document" est bien décoché.
  • Mémoire virtuelle. Dans Windows -> Performances -> avancé -> modifier, j'ai bien "gestion automatique pour les fichiers d'échange pour les lecteurs" coché.
  • Mon système d'exploitation est installé sur mon disque dur principale qui est un SSD, et mes fichiers sont sur le même disque dur.
  • J'ai plus de 100 Go d'espace sur ce disque dur.
  • Mon PC est neuf, bien protégé contre les virus et j'ai pris me suis ruinée pour l'occasion (justement pour ne pas rencontrer ce genre de problème) la plus puissante bécane du moment.
  • Quelque soit la taille mes mes fichiers, même un fichier vierge sans fond en 72ppp avec seulement une courbe fermée composée de 8 noeuds tracés au pinceau (ligne droite simple) présente le même problème de latence.
  • J'ai d'autres logiciels très gourmands qui ne posent pas de problèmes, comme par exemple Shutter Encoder pour réencodage vidéo de BDMV en H265 1080p 10bits... in the nose Big Grin (pour bien comprendre la puissance)
  • J'utilise aussi Gimp et Krita, et une vieille copie de Photoshop 7.0 (celui de 2002). Aucun soucis avec ceux-là non plus. Audacity non plus, mais ils ne sollicitent pratiquement pas mon processeur ni la RAM. L'encodage vidéo est le seul avec lequel mon PC tourne à 100%.
  • Je suis à la sourie conventionnelle, mais avec la tablette (Wacom Intuos 3 A5 Wide), même problème.
La bizarrerie liée à la latence : le fait que parfois, c'est du 1/10ème ou bien du 1 à 2 secondes, cela est aléatoire. A force de pratiquer, j'ai pu convenir qu'en plus de l'éléatoire, je sens que si je bouge lentement le noeud, le noeud à tendence à rester sur place. Il bouge seulement à partir d'une certaine distance.
A cause de cela, quand j'essaie d'aller à une vitesse normale, je dois presque tout le temps m'y reprendre à deux fois, car lorsque je lâche le noeud modifié, il n'a en fait pas du tout bougé Dodgy (pas pris en compte la sélection du noeud, car lorsque je prends le temps de latence et la distance à utiliser, que je laisse le temps au noeud d'affichier la sélection et de  rejoindre le pointeur de ma sourie, cela fonctionne bien). Du coup, pour des petites modifications, je suis obligée de tirer beaucoup le noeud pour ensuite revenir... pas pratique !
Plus il y a de noeuds dans le fichiers, plus les temps de latence et/ou la distance à atteindre est remarqualble.

Une dernière pour vous aider : une vidéo de ce que ça donne chez moi. Parce que en vrai, c'est quand même plus parlant :



Vous pouvez la récupérer en meilleure qualité ici : https://www.farahdouibi.fr/test_LD.mp4 (1:18 minutes et 2 Mo environ)
J'ai pris le plus léger du léger, 72ppp et une courbe simple avec peu de noeuds. Si vous le souhaitez, je peux refaire le test avec un fichier de travail à moi (plus lourd puisqu'en 300ppp et avec pleins de noeuds), et vous verrez que le problème est plus marqué, assez handicapant.

Précision : juste sélectionner un noeud est immédiat, mais du moment que je veux le tirer, le noeud n'est pas de suite sélectionné et donc, ne viens pas immédiatement avec la sourie.


Voilà. Vous avez tout. Merci de m'aider car j'ai vraiment envie de prendre plaisir à utiliser ce logiciel.
Pour le moment, je vous avoue que c'est beaucoup de frustration Sad
Windows 10 pro 64 bits | 64 Go RAM | Intel Core i7-10870H | 2.21 GHz | NVIDIA
Affinity Design v1.9.2.1035 | Wacom Intuos 3 A5 Wide (PTZ-631W)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Vos applications :
  • > Affinity Designer Windows
#2
Je n'utilise pas Designer. Ma réponse est donc à prendre avec circonspection :
D'autres problèmes de latence ont été résolus en décochant "Activation matérielle" dans "Edition / Préférences / Performances".
Plus on apprend, plus on se rend compte de la "vastitude" de son ignorance.
Canon 7D MkII alain29 Windows 10


Vos applications :
  • > Affinity Photo Windows
  • > Affinity Publisher Windows
#3
Je n'utilise pas Designer non plus, mais bravo pour la préparation de ton post !  Cela dit, dans ta vidéo, je ne ressens pas où le problème ; par ailleurs, si je reforme le même exercice dans A.Photo (on a tout de même la plume et le nœud), je ne rencontre pas de difficulté particulière. Du moins, que je ressente, car je ne suis pas habitué aux tracés et je m'y risque sûrement bien plus prudemment que toi. La seule bizarrerie similaire que je rencontrerais réside dans le maniement du réglage par courbe — ça,  j'utilise beaucoup —, et il faut assez souvent que je m'y reprenne à deux fois pour déplacer un point de contrôle. La première fois, « il ne suit pas ». Mais on ne met pas des centaines de points de contrôle dans une courbe, et puis, peut-être vais-je trop vite. Je suis retraité, j'ai tout mon temps ! [Image: tongue.png]

Bref, je n'interviens que pour te faire patienter, attendons que les habitués de Designer se réveillent...
Vos applications :
  • > Affinity Photo Mac
#4
Bonjour Farah,

Est ce que tu pourrais créer un petit fichier Designer comme sur ta vidéo, et mettre un lien pour pouvoir le récupérer. Ça permettra de voir si les même problèmes apparaissent sur un poste différent.
Vos applications :
  • > Affinity Photo Mac
  • > Affinity Designer Mac
  • > Affinity Publisher Mac
#5
@Framon : Merci pour ta proposition. J'ai bien l'accélération matérielle décochée sans changement.

@ch22 : Oui, c'est le même problème que pour toi. Le noeud "ne suit pas" et je dois, comme toi, m'y reprendre à deux fois ou insister avec la sourie pour que le noeud finisse par suivre.
Est-ce que ce ne serait, de fait, pas lié à une latence, du coup ? A autre chose ?
Ou bien le fonctionnement normal du logiciel ?
Je dois cependant avouer que si sur certaines illustrations, j'optimise, c'est-à-dire que j'ai le moins de noeuds possibles et je travaille proprement les vecteurs, il y a d'autres illustrations sur lesquelles il y a beaucoup de noeuds.

@YvanM : J'ai fait un deuxème test ici : https://www.farahdouibi.fr/test2_LD.mp4 (2,2 Mo)
Et le fichier .designer enregistré juste après ici : https://www.farahdouibi.fr/test2.afdesign

Merci à tous les trois.
Windows 10 pro 64 bits | 64 Go RAM | Intel Core i7-10870H | 2.21 GHz | NVIDIA
Affinity Design v1.9.2.1035 | Wacom Intuos 3 A5 Wide (PTZ-631W)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Vos applications :
  • > Affinity Designer Windows
#6
Je viens d'ouvrir ton fichier sur Mac : Aucun problème, pas de latence les points se déplacent instantanément, ça ne vient donc pas du fichier...
Vos applications :
  • > Affinity Photo Mac
  • > Affinity Designer Mac
  • > Affinity Publisher Mac
#7
Merci, YvanM. Cela signifie bien que ce n'est pas normal que j'ai cette latence ou ce retard du noeud.
Reste à savoir pourquoi.
Windows 10 pro 64 bits | 64 Go RAM | Intel Core i7-10870H | 2.21 GHz | NVIDIA
Affinity Design v1.9.2.1035 | Wacom Intuos 3 A5 Wide (PTZ-631W)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Vos applications :
  • > Affinity Designer Windows
#8
Bonjour tout d'abord

Avec la 1.9 est advenu les indices des échelles X, Y, "peut être un peu trop vite fait "
le problème a été objectivé et signalé
Sur le site officiel,  Scott Williams  prévient
" Dans l'ajustement des courbes, je ne suis pas en mesure d'effectuer des mouvements fins des points que j'ajoute.


Si vous ajoutez un point et que vous essayez de le déplacer, il restera dans la même position jusqu'à ce que le pointeur de la souris soit à quelques pixels de la position originale où j'ai placé le point.

Après cela, vous ne pourrez plus déplacer le point à quelques pixels près de la position de placement. Il s'accrochera et passera par-dessus.

Cela empêche le contrôle fin des courbes, ou du moins le rend plus difficile."
D'autres intervenants reconnus,  confirment

Les développeurs sont prévenus.

Pour moi win 10 version 21H1, je n'ai pas eu ce genre de problème sur APhoto

Envoi trop rapide
Des fois que.... Toujours Scott Williams
"De même, lorsque vous sélectionnez un point de courbe à l'aide du sélecteur sur l'image, le point sélectionné n'est pas placé sur la courbe tant que vous n'avez pas déplacé votre souris de quelques pixels. Ce n'est pas exactement cassé, mais cela semble peu soigné. Le point devrait apparaître dès que vous le sélectionnez sur votre image. "
Nikon 610 / Win10  16 go  de  Ram  Affinity Photo 1.7.2.471
Vos applications :
  • > Affinity Photo Windows
#9
Contrairement à ce que ce Scott Williams rapporte, je n'ai aucun problème pour déplacer un point de contrôle pré-existant sur mon Mac. Et quand bien même aurait-on une souris parkinsonnienne, les flèches du clavier sont là pour les déplacements au pixel près (mais cela n'exclut pas les difficultés rapportées)

Quand à la 2ème observation (le point sélectionné qui demande à la souris de bouger un peu) c'est comme ça depuis le début. J'ai toujours pensé que c'était une volonté de se démarquer d'un autre logiciel plus connu... je peux vivre avec.
Vos applications :
  • > Affinity Photo Mac
#10
Merci Max P,
Je comprends enfin Smile
Je ne peux donc qu'attendre une prochaine version avec la rectif (espoir !).

Ch22, je t'avoue que pour moi, cela change beaucoup. J'ai 47 illustrations A4 à redessiner en vectoriel pour mon premier livre, et sans doute autant pour chaque livre chaque an.
Savoir que je perds deux fois plus de temps que nécessaire pour la réalisation de ce travail est assez contrariant. (sans compter de devoir reprendre son noeud à plusieurs reprises) Tongue

Ce logiciel est vraiment sympa, j'espère donc beaucoup de la prochaine mise à jour Smile
Windows 10 pro 64 bits | 64 Go RAM | Intel Core i7-10870H | 2.21 GHz | NVIDIA
Affinity Design v1.9.2.1035 | Wacom Intuos 3 A5 Wide (PTZ-631W)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Vos applications :
  • > Affinity Designer Windows
#11
Je ne parlais pas des tracés, mais des réglages par courbes où j'avais décelé un **petit** défaut. Max P a renchéri là dessus en rapportant des plaintes concernant ces réglages dans la v1.9, plaintes apparemment minoritaires.

De toutes façons, le fait que quelques utilisateurs pâtissent de certains troubles alors que les autres n'en souffrent pas n'implique pas qu'ils ont la berlue. Il faut essayer de comprendre d'où ça vient, et la première difficulté est d'arriver à reproduire ces troubles de manière délibérée afin qu'on puisse mettre le doigt dessus. Ce n'est pas gagné !
Vos applications :
  • > Affinity Photo Mac
#12
Bonjour, Farah_DOUIBI.
Si l’accélération matérielle peut fonctionner, le logiciel permet de l’activer sinon l’encochage est inaccessible.
Installe la version bêta depuis le forum Affinity.
Cela résout-il la lenteur ?
Sinon, écris un message dans le rapport de bogue sur le forum officiel.
Mais je vous le demande, peut-on imaginer une police sans sérifs ?

6 cœurs Windows 10 pro   Affinity Desktop Publisher, Affinity Desktop Designer, Affinity Desktop Photo.
Mais je vous le demande, peut-on imaginer une police sans sérifs ?



Vos applications :
  • > Affinity Photo Windows
  • > Affinity Designer Windows
  • > Affinity Publisher Windows
#13
@ch22, @Max P, j'ai été un peu vite en besogne !
Je continue donc de rechercher.

@Pyanepsion, j'ai téléchargé la beta 1.9.4.1065 et le problème est le même.
J'ai testé avec et sans accélération matérielle, mais le problème reste là, même si ça va un peu plus vite en cochant l'accélération matérielle.
Windows 10 pro 64 bits | 64 Go RAM | Intel Core i7-10870H | 2.21 GHz | NVIDIA
Affinity Design v1.9.2.1035 | Wacom Intuos 3 A5 Wide (PTZ-631W)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Vos applications :
  • > Affinity Designer Windows
#14
Salut les Affinitiens

Je suis avec intérêt les déboires Farah ... car tu es bien la première sur le forum avec ce constat des noeuds qui te pénalise autant !
Depuis 4ans que j'utilise la suite Affinity je n'ai jamais eu ce genre de latence pour modifier et déplacer les noeuds
Pour te dire que ma config n'est pas énorme W10 pro, Processeur I7 et 8 Go de Ram


►As tu fais un " boot "avec la touche CTRL maintenue et de remettre tous tes paramètres utilisateurs en les sélectionnant pour retrouver les paramètres usine en repartant sur de bonnes bases
►la souris et tablette
Les pilotes sont ils à jour ?
As tu essayé avec une autre souris ou une autre tablette pour "comparer" si cette lenteur est due à ce type de matériel?

Cordialement
 ■ Canon 6D  alain29  Fuji X30
APRÈS avoir posé une question ...RÉPONDEZ au membre qui est intervenu ...MERCI
Vos applications :
  • > Affinity Photo Windows
  • > Affinity Designer Windows
  • > Affinity Publisher Windows
  • > Affinity Photo iPad
  • > Affinity Designer iPad
#15
Bonjour,

Je viens de visionner bien agrandie ta vidéo et j'ai remarqué que ta souris "tressautait" elle ne glisse pas bien lorsque tu passe d'un point à un autre, cela induit un manque de précision pour accéder pile poil sur le ti carré.

Toutefois cela ne se remarque pas trop lorsque tu dessines à toute vitesse, bravo pour ça, sauf lorsque tu fermes la boucle le curseur hésite!

DONC peut-être y a-t-il un paramétrage de ta souris pour un déplacement + rapide donc différent de celui actuel, c'est à tenter!  Blush

@+  Wink
Suite Affinity 1.9.3 - macOS Catalina 10.15.7 - iPhoneSE iOS 14.0 - APN Nikon D3100 Wink
Vos applications :
  • > Affinity Photo Mac
  • > Affinity Designer Mac
  • > Affinity Publisher Mac
#16
(01-06-21, 17:01:59)Alain29 a écrit : ►As tu fais un " boot "avec la touche CTRL maintenue et de remettre tous tes paramètres utilisateurs en les sélectionnant pour retrouver les paramètres usine en repartant sur de bonnes bases
►la souris et tablette
Les pilotes sont ils à jour ?
As tu essayé avec une autre souris ou une autre tablette pour "comparer" si cette lenteur est due à ce type de matériel?

Bonsoir Alain,
Comme j'ai installé le version beta, tout était en paramètres usines sur cette installation. Mais le résultat est le même.
J'ai aussi testé deux autres souris mais rien n'a changé, là encore.
J'ai vérifié les pilotes, et ma tablette et mes souris sont bien à jour. Quand j'avais mon ancien PC, j'avais aussi testé avec une autre tablette graphique et le problème était le même.
Merci de t'intéresser à mon cas, Alain29 Smile


Citation :Je viens de visionner bien agrandie ta vidéo et j'ai remarqué que ta souris "tressautait" elle ne glisse pas bien lorsque tu passe d'un point à un autre, cela induit un manque de précision pour accéder pile poil sur le ti carré.

Effectivement, sur la vidéo, on croit que la souris trésaute, cependant, c'est du au logiciel avec lequel g'enregistre mon écran T_T (CamStudio)
En vrai, la souris ne trésaute pas du tout, elle est très fluide. On voit juste la souris partir et le noeud suivre un peu après, sauf quand je vais vite et loin en même temps. C'est pour ça que j'ai fait quelques noeuds vite et loin pour bien montrer que le problème ne se pose pas dans ces conditions.

Merci de vos aides et désolée de ne revenir que maintenant sur le forum.
Je continue de rechercher.
Windows 10 pro 64 bits | 64 Go RAM | Intel Core i7-10870H | 2.21 GHz | NVIDIA
Affinity Design v1.9.2.1035 | Wacom Intuos 3 A5 Wide (PTZ-631W)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Vos applications :
  • > Affinity Designer Windows
  


Atteindre :


Utilisateur(s) parcourant ce sujet :
1 visiteur(s)