Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Pathfinder - problème de soustraction
#1
Bonjour à tous,

J'ai parfois un problème avec la soustraction du pathfinder : à partir d'une forme dans un fichier svg, j'ai voulu l’intégrer dans un cercle et soustraire le picto du dessus, mais à la soustraction certaines formes ne sont pas bien prises en compte...


[Image: e-tape-1.png]


Pour les deux formes qui n'ont pas bien disparues j'ai trouvé, complètement par hasard, qu'en sélectionnant tous les points et en faisant "inverser les courbes" je pouvais avoir ma transparence !  Big Grin

[Image: e-tape-2.png]

Quelqu'un a une idée du pourquoi du comment, après soustraction, les formes étaient toujours bien là mais pas passées en transparence comme les autres, et si on peut y remédier ?  Undecided Je débute encore sur AD, j'étais déjà repassé à illustrator pour une tentative de logo où j'avais rencontré le même souci, mais sans trouvé de solution ce jour-là...

Merci d'avance pour votre expertise Tongue
Vos applications :
  • > Affinity Photo Mac
  • > Affinity Designer Mac
  • > Affinity Publisher Mac
#2
(21-04-22, 18:49:03)ChloéCréa a écrit : mais à la soustraction certaines formes ne sont pas bien prises en compte...
Bonjour ChloéCréa

Le problème que tu rencontres est du à la hierarchie de tes calques .Elle est soit mal structurée ou soit mal sélectionnée
Je m'explique sur ta capture d'écran:
Depuis le panneau des Calques
►il faut absolument que le contenant (ton cercle) soit en bas et que les évidements au nombre de 6 à soustraire soient au dessus
►On Sélectionne tous les objets ( donc 7) et faire ensuite la soustraction

[Image: CAPTURE.jpg]
Ici j'ai réalisé un exemple de 247 évidements circulaires à soustraire sur un rectangle

[Image: CAPTURE.jpg]
 alain29   
APRÈS avoir posé une question ...RÉPONDEZ au membre qui est intervenu 
(EN PRIORITÉ  "Réponse rapide" ou par "Nouvelle réponse")
N'utilisez « CITER CE MESSAGE DANS VOTRE RÉPONSE » qu'avec PARCIMONIE
(seulement sur des EXTRAITS qui vous semblent IMPORTANTS)

Vos applications :
  • > Affinity Photo Windows
  • > Affinity Designer Windows
  • > Affinity Publisher Windows
  • > Affinity Photo iPad
  • > Affinity Designer iPad
#3
Bonjour Alain29,

Merci pour ta réponse ainsi que les images d'exemple Smile
Par contre c'est justement parce que tous les éléments étaient bien au-dessus que je m'étonnais que ça ne fonctionne pas comme il faut.

Après tous les éléments du picto blanc n’étaient que sur un seul calque et non séparés sur des calques différents, je me disais que ça pouvait être lié à ça, mais même en isolant les formes qui ne fonctionnaient pas (les deux en bas à droite) pour les isoler sur des claques séparés (et en effet bien placés au-dessus du cercle) ça ne découpait pas vraiment le cercle Undecided

Ce n'est pas systématique, mais ce n'est pas la première fois que je rencontre ce problème...

J'ai l'impression que je rencontrais surtout ce problème pour un picto que je n'avais pas créé de zéro... il y avait peut-être des soucis dans les formes de base...
songe

Ou alors c'est tout simplement parce que toutes les formes n'étaient que sur un seul calque. J'essaierai d'y faire attention la prochaine fois pour voir si ça arrive encore   Smile
Vos applications :
  • > Affinity Photo Mac
  • > Affinity Designer Mac
  • > Affinity Publisher Mac
#4
(22-04-22, 13:16:10)ChloéCréa a écrit : Ou alors c'est tout simplement parce que toutes les formes n'étaient que sur un seul calque.

Même avec un SVG importé ( construit avec un seul calque ) la soustraction se passe bien sur une forme
Je viens d'en faire le test et n'ai eu aucun problème !

[Image: CAPTURE.jpg]


Serait ce la puissance de ton ordi qui ferait défaut ?
 alain29   
APRÈS avoir posé une question ...RÉPONDEZ au membre qui est intervenu 
(EN PRIORITÉ  "Réponse rapide" ou par "Nouvelle réponse")
N'utilisez « CITER CE MESSAGE DANS VOTRE RÉPONSE » qu'avec PARCIMONIE
(seulement sur des EXTRAITS qui vous semblent IMPORTANTS)

Vos applications :
  • > Affinity Photo Windows
  • > Affinity Designer Windows
  • > Affinity Publisher Windows
  • > Affinity Photo iPad
  • > Affinity Designer iPad
#5
Ça m'étonnerait que ce soit lié à la puissance de mon ordi, il est tout neuf.
Vos applications :
  • > Affinity Photo Mac
  • > Affinity Designer Mac
  • > Affinity Publisher Mac
#6
Cela ne veut pas dire qu'un ordinateur neuf est automatiquement puissant

Tout dépend de son microprocesseur , de sa cadence, de la RAM, etc...
Une 2CV neuve sera toujours moins puissante qu'une vétuste Ferrari 

Avez vous  rencontré le même problème que ChloéCréa ?
Merci de lui répondre
 alain29   
APRÈS avoir posé une question ...RÉPONDEZ au membre qui est intervenu 
(EN PRIORITÉ  "Réponse rapide" ou par "Nouvelle réponse")
N'utilisez « CITER CE MESSAGE DANS VOTRE RÉPONSE » qu'avec PARCIMONIE
(seulement sur des EXTRAITS qui vous semblent IMPORTANTS)

Vos applications :
  • > Affinity Photo Windows
  • > Affinity Designer Windows
  • > Affinity Publisher Windows
  • > Affinity Photo iPad
  • > Affinity Designer iPad
#7
J'imagine bien, et j'avoue que j'ai un peu de mal à comprendre tout ces détails, mais j'ose espérer qu'un iMac très récent n'a rien d'une 2CV, surtout que tout fonctionne parfaitement bien et très rapidement pour le reste. Et le pathfinder ne me semble pas être une fonctionnalité très énergivore...

Enfin, si personne n'a jamais vraiment eu de souci avec ça je suppose qu'il y a juste eu un bug quelque part et que c'est tombé sur moi Undecided  je verrai dans la durée si c'est un problème récurent ou non.
Vos applications :
  • > Affinity Photo Mac
  • > Affinity Designer Mac
  • > Affinity Publisher Mac
  


Atteindre :


Utilisateur(s) parcourant ce sujet :
1 visiteur(s)